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VectorCAST Overview
VectorCAST is a suite of test automation tools:

> VectorCAST/C++ and VectorCAST/Ada automate the unit and integration testing of C, C++, and
Ada code, allowing you to easily test any subset of files (or packages for Ada) in isolation from the
rest of the application.

> VectorCAST/QA enables teams to implement consistent and repeatable processes for managing
test activities and reporting key quality metrics such as code coverage.

This Quick Start Guide is intended to get you started with the basic features of VectorCAST. Use it for
quick reference.

For more detailed information about VectorCAST product features, please refer to theUser's Guides for
VectorCAST/C++, VectorCAST/Ada, Enterprise Testing, and VectorCAST/QA.

Starting VectorCAST (Windows Users)
As you start:Ensure that VectorCAST is installed. Refer to the Installation Guide for detailed
installation instructions.

To start VectorCAST, a startup script is recommended. A startup script makes it easier for you to
understand configuration settings and allows more flexibility regarding the initial startup. It is a good
practice to have two scripts, one to setup the environment and another to start VectorCAST. For
example, youmay have a need to integrate VectorCAST into a CI system such as Jenkins, and having
a script that only sets up the environment will be useful.

To begin, create an empty directory you can use for the examples in this guide. There can be no spaces
in the path and there are some restricted characters, so it is suggested to start off simple. In this
example, we use D:\setup_dir.

In this example, we have two environment variables that VectorCAST uses to find where VectorCAST
is installed and identify what licensemanager it should use. There aremultiple ways to do this, but to
get started, we will start with a basic example.

Environment Variable Purpose Example Setting

VECTORCAST_DIR Full path to the folder where
VectorCAST is installed D:\VCAST\2022-beta

VECTOR_LICENSE_FILE

Points to the base directory of the
license manager. It has the format
portnumber@ipaddress or
hostname

7650@licenseserver.domain.com

Create a script file like the one shown below and name it setup_env.bat

@ECHO OFF

REM VECTORCAST_DIR - Environment variable pointing to the base directory for VectorCAST.
SET "VECTORCAST_DIR=D:\VCAST\2022-beta"
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REM VECTOR_LICENSE_FILE - Environment variable pointing to the license file
SET "VECTOR_LICENSE_FILE=7650@licenseserver.domain.com"

Create a script file like the one shown below and name it Start_VectorCAST.bat.

@ECHO OFF

CALL setup_env.bat
ECHO VECTORCAST_DIR is set to: %VECTORCAST_DIR%
ECHO VECTOR_LICENSE_FILE is set to: %VECTOR_LICENSE_FILE%

REM Start VectorCAST
%VECTORCAST_DIR%\vcastqt

Now open a command prompt and run the Start_VectorCAST.bat script.

If all goes well, you should see the VectorCAST GUI.

Starting VectorCAST (Linux Users)
As you start:Ensure that VectorCAST is installed. Refer to the Installation Guide for detailed
installation instructions.

To start VectorCAST, a startup script is recommended. A startup script makes it easier for you to
understand configuration settings and allows more flexibility regarding the initial startup. It is a good
practice to have two scripts, one to setup the environment and another to start VectorCAST. For
example, youmay have a need to integrate VectorCAST into a CI system such as Jenkins, and having
a script that only sets up the environment will be useful.

To begin, create an empty directory you can use for the examples in this guide. There can be no spaces
in the path and there are some restricted characters, so it is suggested to start off simple. In this
example, we use /home/vector/setup_dir.

In this example, we have two environment variables that VectorCAST uses to find where VectorCAST
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is installed and identify what licensemanager it should use. There aremultiple ways to do this, but to
get started, we will start with a basic example.

Environment Variable Purpose Example Setting

VECTORCAST_DIR
Full path to the folder where
VectorCAST is installed /home/vector/vcast/2022-beta

VECTOR_LICENSE_FILE

Points to the base directory of the
licensemanager. It has the format
portnumber@ipaddress or
hostname

27000@192.168.0.70

Create a script file like the one shown below and name it setup_env.sh

#!/bin/bash

# VECTORCAST_DIR - Environment variable pointing to the base directory for VectorCAST

export VECTORCAST_DIR=/home/vector/vcast/2022-beta

# VECTOR_LICENSE_FILE - Environment variable pointing to the license file

export VECTOR_LICENSE_FILE=27000@192.168.0.70

Create a script file like the one shown below and name itStart_VectorCAST.sh.

#!/bin/bash

. ./setup_env.sh
echo "VECTORCAST_DIR is set to: ${VECTORCAST_DIR}"
echo "VECTOR_LICENSE_FILE is set to: ${VECTOR_LICENSE_FILE}"

# Start VectorCAST
${VECTORCAST_DIR}/vcastqt

Now open a shell and run the script.

If all goes well, you should see the VectorCAST GUI.
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Troubleshooting
If the script did not work, there are a few things to check to be sure you have everything correct:

> Check that the path to the VectorCAST installation is correct
> It's possible youmistyped the path to where VectorCAST is installed.
> If the path is very long or has special characters, it may not work.
> If the path is on a networked filesystem, theremay be issues.
> If you are sure the path is correct, maybe re-installing on a local disk with a simple pathnamewill

fix the problem.

VectorCAST Interface
Below we discuss the default controls of the VectorCAST GUI. Note that you can return to this
default arrangement at any time by using: View =>Default Layout from themenu bar.

The VectorCASTmain window is divided into four panes:

> The Project Tree is located on the left-hand side of themain window. It provides a high level view
of the project structure.

> The Message Window is located along the bottom left of themain window. It contains tabs for
informational messages and for error messages.

> The Multiple Document Interface (MDI) Window is located to the right of the Project Tree. It
displays a variety of windows, including Test Case editors, Coverage Viewers, Report Viewers
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and Text Editors. Windows are collected into groups. See theVectorCAST User Guides for more
information onMDI Window Groups.

> The Jobs Monitor is located on the bottom of themain window. It displays the status of jobs as
they execute and exposes the associated back-end commands. See theVectorCAST User's
Guides for more information on the Jobs Monitor.
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Create a VectorCAST Project
Enterprise Testing is a Test Automation Framework that sits on top of VectorCAST/C++ or
VectorCAST/Ada test environments and allows test design, execution, and reporting to be distributed
across the enterprise. The VectorCAST Project supports a variety of work flows allowing for team
collaboration, testing of multiple configurations, change-based testing, andmassively parallel testing.

Enterprise Testing can import existing VectorCAST/C++ and VectorCAST/Ada test environments, or
be used to create new environments.

In this section, you will create a new VectorCAST Project starting with an initial unit test environment.

To prepare for this step, some initial setup is required. First, you will copy the source files used in this
example. The following examples show how this is done for bothWindows and Linux hosts.

Windows Example

Linux Example

Next, you will start VectorCAST using the Start_VectorCAST.bat script located in this directory.

Set the Working Directory
Once VectorCAST starts and theGUI opens, you will set the working directory to the directory you

Rev: 607c020 VectorCAST Quick Start Guide for VectorCAST 2023



CREATE A VECTORCAST PROJECT 12

created above (lab01).

From theMenu Bar, select File => Set Working Directory.... Navigate to your working directory and
select Choose. For our example, we select the lab01 directory as our working directory.

Create a New Project
Create a new empty project by selecting File => New => VectorCAST Project => Empty Project
from theMenu Bar.

The next step is to name the Project and select a compiler suite to use. The compiler suite selection will
be different depending on if you are usingWindows or a Linux host. WithWindows, VectorCAST
includes aWindows MinGW compiler that can be used. For Linux, you need to use a native gcc
compiler and insure that the compiler is on the current path.
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Windows Example

Linux Example

Select theCreate button. The new VectorCAST Project, lab01, is displayed in the Project View.

Add a Unit Test Environment
Expand the Project Tree and right-click on theGroup node. Select Create Unit Test Environment =>
Interactive from the context menu.
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The Create New Environment wizard opens.

Enter the Environment name. Our example environment is named UNIT_TESTS. Select theNext
button.

Select the Testing Method. For our example, we select Traditional Unit Testing. Select theNext
button.
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Select the Coverage Type. Using the Coverage type drop-downmenu, select Statement coverage.
Select theNext button.

Add Search Directory. Add a Search Directory recursively by selecting the
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button. Add the c directory that was created earlier. Select theChoose button.

Use Relative Paths. Check theUse relative paths checkbox. Select theNext button.

Choose the UUT. For our example, we will select manager.c as our UUT. Under the Unit Names

tab, select manager.c. Click themove-to-right button to place manager.c in the Units Under
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Test list.

Build the Environment. Once a UUT is designated, theBuild button is enabled. Select theBuild
button.
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You now have an initial Unit Test environment in your VectorCAST Project.

Add a Test Case
To add a test case, select the UNIT_TESTS environment in the Project View and double-click on the
selection. The environment opens in the Environment View pane. All the manager.c functions are
displayed in the Environment View.

Select Add_Party_To_Waiting_list and right click. Select Insert Test Case from themenu to
open the Unit Test Case Editor.

You will see that VectorCAST has already parsed the UUT and all the parameters and their type are
listed. For this unit, we have one parameter called “Name” which is of type string. For this test case,
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wewill add a string to pass to the unit. Select the cell under Input Values on the same row as “Name”.
Type in Vector.

Right-click on the test Add_Party_To_Waiting_List in the Environment View and select Execute
from themenu.

Once the test executes, the Coverage Viewer opens and you will see the lines that were executed as a
result of this test displayed in green.
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Close the environment and return to the Project View by selecting File => Close Environment from
theMenu Bar.

A dialog box appears asking you to confirm the changes youmade to the environment. Select the
Accept Changes button. The Project View is displayed.

Execute All Tests
To execute all of the tests in the lab01 project, right-click on the Project Name (lab01) and select
Execute from the context menu.
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You can follow the execute process in theManage Status viewer which opens in theMDI Window. As
test cases are executed data is stored in a SQL database and used to generate reports showing testing
status and trends, making it easy to analyze regression trends.

The Status Panel updates to display testing status. On the status panel you will see status for the
Environment Build, Test Execution and Statement Coverage. Hover over the Statement Coverage bar
to see a pop-up of the Build and Coverage details.
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